Kudos Recognition
Incident Report for Kudos
Resolved
This incident has resolved.
Posted Sep 19, 2022 - 12:41 MDT
Identified
We've identified the issue and are currently working on a solution
Posted Sep 15, 2022 - 15:05 MDT
Investigating
We are currently investigating an issue with Kudos Recognition. Users may experience a delay in their recognition being processed.
Posted Sep 15, 2022 - 09:40 MDT
This incident affected: Kudos Service.